yum -y install cockpit cockpit-machines cockpit-dashboard cockpit-docker cockpit-storaged libvirt-dbus
systemctl start cockpit
systemctl enable cockpit.socket
firewall-cmd --add-service=cockpit
firewall-cmd --add-service=cockpit --permanent
firewall-cmd --add-port=5201/tcp --permanent
firewall-cmd --reload

script:

curl -O https://mirror.galaxydata.ru/share/scripts/cockpit-host.sh
sh cockpit-host.sh

or

Install Only Cockpit

script:

curl -O https://mirror.galaxydata.ru/share/scripts/cockpit-vm.sh
sh cockpit-vm.sh
yum -y install cockpit cockpit-storaged
systemctl start cockpit
systemctl enable cockpit.socket
firewall-cmd --add-service=cockpit
firewall-cmd --add-service=cockpit --permanent
firewall-cmd --reload

 

Edit SSL Cockpit directory

nano /etc/cockpit/ws-certs.d/0-self-signed.cert

Add Firewall RouterOS

/ip firewall filter add action=drop chain=forward comment=cockpit-allow dst-address-list=cockpit-drop dst-port=9090 protocol=tcp src-address-list=!cockpit-allow
/ip firewall address-list add address=1.1.1.1 list=cockpit-allow
/ip firewall address-list add address=1.1.1.2 list=cockpit-drop

Where ip:

1.1.1.1 your ipaddress in access

1.1.1.2 cockpit panel on kvm server host

Input in Cockpit Panel Https

Example:

https://1.1.1.2:9090

cockpit panel centos

Добавить комментарий

Ваш адрес email не будет опубликован. Обязательные поля помечены *

Этот сайт использует Akismet для борьбы со спамом. Узнайте, как обрабатываются ваши данные комментариев.